Delayed Deposits 11/15
Incident Report for Toast System
Resolved
This incident has been resolved.
Posted Nov 16, 2024 - 12:49 EST
Investigating
We're aware of an issue with deposits for a subset of customers. We are alerting you to let you know you may not have received all or part of your expected deposit today. We are expecting deposits to be received before the end of the day.

Thank you for your patience.
Posted Nov 15, 2024 - 09:01 EST
This incident affected: Deposits.